Tuya devices not triggering logicblocks

Hi there,

I have a tuya door sensor that triggers logicblocks when open and closed, along with a smart plug that triggers logicblocks when switched on. Everything was working fine since I set them up last week, but as of this morning they are not triggering logicblocks. I can’t even see their status updating in the feed.

Any ideas? I’ve tried deleting and relinking my tuya account.


Hello welcome to the community, I have been advised by @pebneter that there was an issue but they have restarted the service they have with Tuya and everything should be working fine.

HI @nickchesterfield,
there was an issue with the Tuya interface and we are currently in touch with Tuya to find out what happened. https://twitter.com/apilio_iot/status/1348614801187024897

Just to add - there still seems be an issue with this today (you may already be aware of it).
Any changes on my TUYA devices (switch on/off) are not updating the conditions which mean the logic blocks are not getting evaluated.


Hi @joe.ferris,
we are trying to locate the cause for this.
For now, we are not seeing a anomaly in the log types and the volume, so it looks to us that there is no widespread issue affecting a lot of people.
If you can connect with us through the chat, you can supply us with some information which devices you expected to change and we can dig a bit deeper to track those down.

Hi Philipp,

Just wondering if you’ve had any update on this issue regarding TUYA devices not reporting their status into Apilio and as a result Apilio conditions are not being updated for the device?
I did a bit more testing today on this and noticed something odd.
While most of my devices are not working in this regard (device state update) I found that a few are working.
I tried two different bulbs - they are both by the same manufacturer and are the same model/type.
One Apilio condition updates true/false when I switch the light on/off whereas the other one’s condition never updates?
Both of these bulbs would have already had conditions configured and would have been working up until recently.

Just thought I’d mention this in case it helps with finding the cause.
All my TUYA devices are working correctly through the Smart Life app on my phone and I can switch on/off all devices successfully via Apilio (e.g. at 7am switch on light X).


We are in discussions with Tuya support on this and we are in the process of narrowing down the potential areas of failure.
I will keep you updated!

Thanks Philipp,

Since approx 7pm this evening everything appears to be working correctly again for me without any configuration changes?
I say 7pm as that’s when I noticed the Apilio conditions began updating correctly based on the TUYA devices changing.

Not sure if it will remain working but just thought I’d let you know anyway.

Best regards,

*** EDIT ***
I thought all was good but today (14/01) it’s back to being intermittent again (some device status updates working some of the time).

1 Like

We are trying to work with Tuya support to locate the error, but no success so far :frowning:.
They can’t find anything wrong on their side, and so can we. We know that some events go missing, but not where…
What we are trying to do now is to reproduce a “missing” event and have an exact timestamp of the event so we can ask Tuya support to follow one specific event.
If you happen to observe another problem, it would be great if you could note down the exact time you did a change on the device (e.g. switch on at xx:xx) and have evidence that that event was sent to the cloud (e.g. with a screenshot or video of the status update the app provides, or a history of event that the app provides).

Thanks Philipp,
I’m not sure how I can show the evidence of the request was sent to the cloud other than physically the light switches on in the room?

Here’s an example of a simple bulb on/off test.
I have an Apilio condition called officeLightOn:

I have a logicblock that turns on this bulb every day at 7am.
From the last reported value on this condition you can see that this worked this morning at 7am and indeed the bulb was switched on successfully.
However, if I try switching the device on/off at the moment this last reported value does not update.
I have switched the device off at 11:09am and back on a few seconds later using my Smart Life app on my phone. The bulb immediately switched off and back on as I expected but the last reported value in Apilio remains as 07:00:04 with the status as of that time.

I also tested using a logicblock in Apilio rather than via the Smart Life app.
So I created a simple logicblock that triggered at 11:24am today.
It’s action was to switch on the office light.
At 11:24 the logicblock was triggered and the bulb immediately switched on in the office.

However, when I check the last reported status on the condition it still is 07:00:04 from earlier this morning.


1 Like

Hi Philipp,

In case it’s relevant I just repeated the same test with the office light again a few minutes ago and the status is updating now in Apilio (no configuration or hardware changes made).
I switched the light off then back on (via Smart Life app) and both states were reported correctly.
See screenshots of the conditions below with the times if you need them.



1 Like

Hi @joe.ferris,
thanks a lot - those examples help especially with the exact times so I can forward them to Tuya for inspection. Those were all on the 15th January and GMT / UTC time?


Thanks Philipp,
Yes that’s correct, 15th Jan and GMT/UTC time zone.