Ecobee, IFTTT, Apilio failing

Ecobee, IFTTT, Apilio failing
0

#1

I started using APILIO probably around a year ago and everything for while was working perfectly - but something started going wrong and is still not working right now.

I have a heat source that I am trying to use to heat our house. I initially was using IFTTT alone - BUT there was too much delay between it turning on/off my devices - they NEED to happen nearly at the same time. That was how I ran upon APILIO when looking for a solution.

Currently, I am using an Ecobee thermostat’s temperature reading in IFTTT to update a Boolean APILIO variable to True when the temp goes below 69 or sets it to False if the temp goes above 69 degrees. The thermostat controls 2 other heat sources (primary and secondary) if the temp goes below 68 degrees. There are 4 fans I am controlling on this 3rd heat source which is now acting as the real primary (the other 2 being controlled by the thermostat are now effectively secondary and tertiary). 2 of the fans blow outside, the other 2 blow inside. When the Boolean variable becomes True - it turns off the 2 fans blowing outside and the turns on the fans bowing inside. When the variable becomes False, this reverses and turns off the 2 fans blowing inside and turns on the fans blowing outside. This must happen close together as the are the cooling system for my heat source - at least on pair of these fans must always be running.

However, after a while, this I started getting Applet Failed errors on these Ecobee applets. But it seems that the Ecobee part may be working right - as it tries to run at different times and fails - most of the time anymore - BUT sometimes it does not fail and works properly. The thermostat also controls a cooling source that will kick in above 70. I know these numbers sound close - but it was working great - until these applet failures. When the fail to update, the heat source stays on too long or off too long. Making the thermostat turn on it’s heat sources or or turn on the cool air to combat the heat being pushed into the house - either way wasting money. And, the heat source is stronger than the cool air and it overtaken. If this were only an issue of a few minutes - not too big of a deal - but it got to the point that many hours and eve days would pass between the applets not failing. So, I ended up having to stop using this setup. A real shame as it has been effectively heating our house down to 12 degrees outside. That’s a lot of wasted energy.

So, I am trying to see if anyone here can help me figure out what is going wrong, where, and if there is a solution. I had actually spent a while developing a custom circuit based on a Raspberri Pi computer to control all of this locally - but the weather is starting to cool down where this could be used now (still not working) and I only have a design for me circuit system - no actual circuit board. Any help would be appreciated.

Thanks!


#2

Hi there!
We are happy to help finding the source of the errors. What are the messages you are getting and which component do you suspect to be failing?

Cheers
Philipp


#3

Sorry for the delay in getting back to you.

The IFTTT error is Applet Failed. As an example, this on also says Oct. 6 - 9:30 AM. I click on Show Details and it says No details Available. This applet is an Ecobee Applet with Webhooks. It allows me to do something when the indoor temperature measured by my Main Floor thermostat is less than 69. When this happens, it makes a web request which I have the URL set to: https://apilio.herokuapp.com/boolean_variables/MainFloorTempLT69/set_true/with_key/xxx (changed for posting here obviously) and the Method is GET with no Content Type selected and no Body.

The Applet Failed message also says “The ecobee service or its API may temporarily be down” But, wouldn’t their applet firing be what caused it to run in the first place - and then getting the error? I’m not 100% sure what the implications of this means or if it is accurate.

I have another one of these that should fire when the indoor temperature measured by my Main Floor thermostat is more than 69. In this case is uses the link to set my Apilio boolean variable to false.

Both of them have these same kind of failures. Ecobee says they are fine. IFTTT… Things here seem to work fine. When I use the links to set my boolean variable directly - they change immediately. So I don’t know it this is IFTTT not firing the applets properly, Ecobee api issues, some issue with IFTTT calling the URLs to set the Apilio variable. Debugging this seems nearly impossible.

I also notice that on either the IFTTT web site or phone app, if I click on the Check Now button on the applet settings that it doesn’t do it. It’s like I never hit it. The activity log does not show it ran right then or minutes later when it says it usually runs in a few seconds.


#4

So, just now. I have this all turned on. The primary heating system (being controlled by all of this - Ecobee/IFTTT/Apilio) just went above 69 on the thermostat. Then to 71. Yet on IFTTT, the applet never ran - no error either - but didn’t run at all. At lease as far as the View activity list shows. It says the last time it ran was at 6:03PM (2 hour 16 minutes ago). My understanding is that my Ecobee thermostat temp is sent to Ecobee, who in turn allows IFTTT to read them, or they push the data to IFTTT (which seems like that was how it was working originally as it responded very quickly when the temps reached these threasholds), which then causes these applets to run and do stuff. But in this case it hasn’t even ran - cause the thermostat to kick in the AC to combat the rising house temp. So, I logged in here to Apilio and changed the value of my boolean varialbe - and within a few seconds - the heating system fans went off (to the house) and turned on the ones blowing outside. This is not the same issue as the applet failures but is adding to the problem. Not running when they should and then failing too.


#5

To me this sound as if the issue was with the Ecobee <-> IFTTT interface.
Pushing data to IFTTT is actually a two-step process: The external system first informs IFTTT that there is new data, which then IFTTT fetches from Ecobee. So it is possible the first step occurs, but then the second one fails.
Do you have any chance to contact Ecobee and make sure they have no issues with their interface?