Apilio Numeric countdown variable stuck halfway and causing IFTTT fail to turn off aircond

Apilio Numeric countdown variable stuck halfway and causing IFTTT fail to turn off aircond
0

#1

Hi all,

I follow this document from Google Group to setup the linkage between IFTTT, Google Assistant and Apilio.
https://docs.google.com/viewer?a=v&pid=forums&srcid=MDM5NTIwMTA2NDI5MDYxMjgzNDMBMDI3NDcwMTUxMTA3MzUwMjcxMzYBMVIxcXZxVVZDQUFKATAuMQEBdjI&authuser=0

My main aim is as below.
I use Google Assistant to give command “Hey Google, schedule the aircond for 120 mins”.
Then use Apilio numeric variable as a countdown timer for the 120 mins.
After 120 mins (2 hours), the Apilio will notify IFTTT to turn off my aircond.
This setup is working fine for few months even though i didn’t use it daily.
But recently, the numeric timer just stuck half day and didn’t continue.
As a result, my aircond keep working until I wake up around 5 am.
I check at IFTTT activity log and found out that the Applet fail around 11.36pm.
After that failure, the timer countdown didn’t continue.
I double check the numeric variable in Apilio web app and notice it stuck at 91 mins.
Is Apilio having server down and causing this issue recently?
Anyone encounter similar issue like this? Any solution are welcome.
Thanks a lot.


#2

Another screenshot of the error from IFTTT activity log.


#3

Thanks for the great question. We didn’t have any scheduled downtime or outage we’re aware off but will take a look through the logs and report back shortly.


#4

Thanks. Looking forward for your reply.
The failure time is 20 Oct 2019 11.34 pm (GMT +8).
Possible to set any retry on the countdown timer if the applet fail?


#5

Hey there,
I checked the logs and cannot see any incoming triggers around the mentioned timeframe. Maybe because IFTTT had an issue, but it could also be that Apilio is to blame.
I see that there are some recent log entries for your setup that seem to look fine - is your setup currently still failing?


#6

Hi,
I use it yesterday for 30 mins and it’s working fine.
Previously I scheduled it for 120 mins.