Tado Heating IFTTT Trigger not updating Apilio Variable

Tado Heating IFTTT Trigger not updating Apilio Variable
0

#1

Hi - I’ve set up an IFTTT Tado Heating trigger to set an Apilio Variable, but although everything is connected correctly, the temperature changes on Tado don’t seem to get through IFTTT to Apilio. The IFTTT recipe reports that it has never run. The strange thing is that other Tado temperature related triggers on IFTTT will correctly trigger notifications or emails, for example.

So, I’m just wondering if anyone has successfully managed to use Tado on IFTTT to change an Apilio variable? I did have this working in early 2019, by using an IFTTT webhook into Apilio, but it stopped around March 2019. I’ve now tried the direct IFTTT / Apilio Action, but it still doesn’t work.

I don’t know if this is likely to be a Tado issue, an IFTTT issue or an Apilio issue - any suggestions would be appreciated.


#2

Hi there, if the IFTTT applet is reporting it’s never been run then the issue looks Tado/IFTTT related I’m afraid. How is the Tado-IFTTT-Apilio integration currently setup?


#3

Hey @Signal_engineer,
I have a Tado thermostat as well and just tried to save a temperature to an Apilio numeric variable.
That worked without problems in my case. Did you check if the temperature threshold was triggered in IFTTT in your setup?


#4

Hi DanT

If have a Tado 1st generation system heating controller. On IFTTT I use a trigger from Tado (temperature rises above a set point or falls below a set point) to initiate an action on Apilio to set a boolean variable (temperature_set_point_reached) to either false or true). This, and other variables, are used to set conditions in Apilio and are processed in logic blocks to control central heating booster fans using an Apilio action (webhook into a Smart Life Socket group).

The tado temperature change trigger works correctly with actions like send a notification or an email, but doesn’t seem to be triggered in IFTTT to update the Apilio variable. If I use the Tado Humidity increase/decrease trigger, it does correctly update an Apilio variable, so I’m really trying to find out why only the temperature change triggers don’t seem to work.

I’ve previously asked Tado, but they say everything is working correctly at their end. It does seem to be an IFTTT issue - do you have any suggestions for how best to raise this with them?

Thanks


#5

Hi @pebneter,

Thanks for your reponse. The IFTTT is not being triggered (recipe settings details state ‘never run’), despite the fact that other IFTTT actions (send a notification) are correctly triggered at the same temperature values. How did you save a temperature value from Tado? - that may be a workaround for me to explore.


#6

Here’s a screenshot of the applet configuraiton: