How to fix unwanted delays when triggering IFTTT

How to fix unwanted delays when triggering IFTTT
0

#1

Using inactive/outdated IFTTT Webhooks Service API Key can lead to unexpected delays

Problem description

You have setup Apilio and some actions that trigger IFTTT applets. Everything seems to work fine, except that the actions you trigger on IFTTT have a big delay (let’s say between tens of minutes up to a couple of hours).
You have not setup any delay in Apilio and also not configured any delay for a for warning or suggestion execution mode.

Solution

In almost all cases, the source for this problem is an outdated IFTTT Webhooks Service API Key. This key is necessary to authenticate your trigger from Apilio to IFTTT. It is automatically generated by IFTTT whenever you activate the Webhooks Service on IFTTT.
You can find you access key on the Webhooks settings page.

The exact same key must be configured in Apilio on your user profile. Just copy the complete URL string or just the last, cryptic part after “https://maker.ifttt.com/use/”.

Solution

Compare the current IFTTT Webhook Service API Key from the IFTTT settings page with the key configured on your Apilio user profile. If the keys are not identical, update the key in Apilio with the current one from IFTTT.
To check if this solved the delay issue, trigger the action manually by clicking the action link from the logicblock or by evaluating the logicblock again.
The delay that has to be expected by using Apilio and IFTTT (and which can not be reduced further) is around 2 to 5 seconds.


#2

This advice fixed a problem I’ve been having for the past 3 days. Thanks!


archived #3

unarchived #4

unlisted #5

archived #6